站内
QQ客服
自定内容
自定内容
请输入内容
新闻搜索
 
 
新闻动态
CISCO PIX 520 防火墙配置
成都狮龙书廊科技有限责任公司长春分公司    2016-03-11 18:06:24    文字:【】【】【
摘要:CISCO PIX 520 防火墙配置

CISCO PIX 520 防火墙配置

从结构上讲,CISCO PIX 520 防火墙是一种 pc 式的电脑主机加
上闪存(flash)和防火墙操作系统。它的硬件跟工控机差不多,都
是属于能适合 24 小时工作的,外观造型也是相类似。闪存基本上跟
路由器一样,都是那中 eeprom,操作系统跟 cisco ios 相似,都是命
令行(command)式。PIX 520 是一种机架式设备,从前面板看,
只有 1 个指示灯(正常运行时常亮,黄色),右侧有 2 个以太口(都
是 100M 网卡,左为 ethernet0,右为 ethernet1),1 个配置口
(console),1 个 15 针的 failover 口,还有 pci 扩展口;左侧有 1
个软驱(平时用挡板遮盖)。
配置方式与 cisco 路由器相同,用配置线从电脑的 com1 连到
PIX520 的 console 口,进入 PIX 操作系统采用 windows 系统里的“超
级终端”,通讯参数设置为默然。
 
 特别说明:防火墙命令大小写通用,并且可以使用缩写方式,所
有模式都可以用“show”命令显示系统当前配置。
 
pixfirewall# wr erase //清空防火墙原有配置
Erase PIX configuration in flash memory? [confirm] //回车
pixfirewall# rel //重新启动系统
Proceed with reload? [confirm] //回车
 
Rebooting....
Cisco Secure pixFirewall BIOS (3.6)  2
Booting Floppy
Flash=i28F640J5 @ 0x300
Reading 1937920 bytes of image from flash.
 
##########################################################
###############################################
128MB RAM
mcwa i82559 Ethernet at irq 11 MAC: 00d0.b73e.3b08
mcwa i82559 Ethernet at irq 10 MAC: 00d0.b73e.3a7e
Flash=i28F640J5 @ 0x300
BIOS Flash=AT29C257 @ 0xfffd8000
 
 -----------------------------------------------------------------------
 || ||
 || ||
 |||| ||||
 ..:||||||:..:||||||:..
 c i s c o S y s t e m s
 Private Internet eXchange
 -----------------------------------------------------------------------
 Cisco PIX Firewall
 
Cisco PIX Firewall Version 6.3(3) //防火墙软件版本
 
Licensed connections: 65536
 
 
Copyright (c) 1996-2003 by Cisco Systems, Inc.
 
 Restricted Rights Legend
 
Use, duplication, or disclosure by the Government is  3
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.
 
 Cisco Systems, Inc.
 170 West Tasman Drive
 San Jose, California 95134-1706
 
 
Cryptochecksum(changed): d41d8cd9 8f00b204 e9800998 ecf8427e
Pre-configure PIX Firewall now through interactive prompts [yes]? n
//初始使用有一个初始化过程,主要设置:date(日期)、time(时
间)、hostname(主机名称)、inside ip address(内部网卡 ip 地址)、
domain(主域)等,如果以上设置正确,就能保存以上设置,也就建
立了一个初始化设置了。
此处输入“n”,退出初始对话框。
Type help or '?' for a list of available commands.
pixfirewall> en
Password:
//进入 PIX520 采用超级用户(enable),默然密码为空,修改密码
用 passwd 命令。一般情况下 firewall 配置
pixfirewall# show ver //显示系统软硬件信息
Cisco PIX Firewall Version 6.3(3)
Compiled on Wed 13-Aug-03 13:55 by morlee
pixfirewall up 48 secs  4
Hardware: SE440BX2, 128 MB RAM, CPU Pentium II 350 MHz
Flash i28F640J5 @ 0x300, 16MB
BIOS Flash AT29C257 @ 0xfffd8000, 32KB
0: ethernet0: address is 00d0.b73e.3b08, irq 11
1: ethernet1: address is 00d0.b73e.3a7e, irq 10
Licensed connections: 65536
Serial Number: 18055291 (0x113807b)
Running Activation Key: 0x7656600b 0x7dd0efde 0x91801941
0xba66aa44
Configuration last modified by enable_15 at 03:27:45.420 UTC Fri
Feb 18 2005
pixfirewall#
pixfirewall# show config //显示初始配置为空
No Configuration
pixfirewall# show start //显示初始配置为空
No Configuration
pixfirewall# show run ////显示系统默认配置
:
PIX Version 6.3(3)
interface ethernet0 auto shutdown //默认关闭
interface ethernet1 auto shutdown //默认关闭
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted //默认口令为空
passwd 2KFQnbNIdI.2KYOU encrypted  5
hostname PIXfirewall
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
pager lines 24
mtu outside 1500
mtu inside 1500
no ip address outside //默认无地址
no ip address inside //默认无地址
ip audit info action alarm
ip audit attack action alarm
no failover //默认无双机
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
pdm history enable
arp timeout 14400
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
1:00:00  6
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e
: end
PIXfirewall#
 
基本配置如下:
1、 建立主机名和修改密码
PIX520#config t //进入特权模式
PIX520(config)#
PIXfirewall(config)# enable password cisco //设置口令为“cisco”
PIXfirewall(config)# hostname PIX520 //设置主机名为“PIX520”
PIX520(config)#
跟 cisco ios 路由器基本一样。
2、 激活以太端口  7
PIX520(config)#interface ethernet0 auto
PIX520(config)#interface ethernet1 auto
 在默然情况下 ethernet0 是属外部网卡 outside, ethernet1 是属
内部网卡 inside, inside 在初始化配置成功的情况下已经被激活生效
了,但是 outside 必须命令配置激活。
3、 命名端口与安全级别
PIX520(config)#nameif ethernet0 outside security0
PIX520(config)#nameif ethernet1 outside security100
 
采用命令“nameif”。security0 是外部端口 outside 的安全级别
(0 安全级别最高) security100 是内部端口 inside 的安全级别,如
果中间还有以太口,则 security10,security20 等等命名,多个网卡
组成多个网络,一般情况下增加一个以太口作为 dmz(demilitarized
zones 非武装区域)。
4、 配置以太端口 ip 地址
采用命令“ip address”。
如:内部网络为:192.168.1.0 255.255.255.0
外部网络为:200.11.11.0 255.255.255.0
PIX520(config)#ip address inside 192.168.1.1 255.255.255.0
PIX520(config)#ip address outside 200.11.11.1 255.255.255.0
5、 配置远程访问 telnet
在默然情况下,PIX 的以太端口是不允许 telnet 的,这一点与路
由器有区别。inside 端口可以做 telnet 就能用了,但 outside 端口还跟
一些安全配置有关。
PIX520(config)#telnet 192.168.1.1 255.255.255.0 inside
PIX520(config)#telnet 200.11.11.1 255.255.255.0 outside
测试 telnet
在[开始]->[运行]
telnet 192.168.1.1
PIX passwd:
输入密码:cisco
6、 访问列表(access-list)  8
 此功能与 cisco ios 基本上是相似的,也是 firewall 的主要部分,
有 permit 和 deny 两个功能,网络协议一般有 ip|tcp|udp|icmp 等等,
如:只允许访问主机:200.11.11.254 的 www,端口为:80
PIX520(config)#access-list 100 permit ip any host 200.11.11.254
eq www
PIX520(config)#access-list 100 deny ip any any
PIX520(config)#access-group 100 in interface outside
7、保存结果
保存当前配置采用“write memory”

 

浏览 (203) | 评论 (0) | 评分(0) | 支持(0) | 反对(0) | 发布人:毛凌国. 中国
将本文加入收藏夹
 
 
自定内容
请输入内容<--狮龙书廊跑马灯文件代码区->
自定内容

 

感谢您注册参加技术达人“秀”—“数字化变革新旗舰5K智能协作终端发布”在线研讨会。

活动日期:2017年6月8日     
北京时间:上午10:00-11:00
活动号:204 914 711
活动密码:170608
 网站编辑@ 2017 年成都狮龙书廊科技有限责任公司。
Cisco、Cisco Systems和Cisco Systems标志是思科系统有限公司和/或其子公司在中国和特定国家和地区的商标或注册商标。
本文中涉及的所有其它商标均属于各自所有者的资产。
自定内容

请输入内容

自定内容

欢迎参加第五届豆瓣阅读征文大赛

详情
豆瓣阅读  发送至 public  
隐藏
发件人:豆瓣阅读  
收件人:
public  
抄 送:
密 送:
时 间:2017-08-11 15:28
时 间:
地 点:
邮件已加密,收件方查看邮件需要密码。 邮件已加密,密码:
  • 回复
  • 转发
查看译文
查看原文
对照显示
正在翻译,请稍候...
自定内容

美橙视频制作中心

独特创意 精妙制作 品质铸造 超高性价比
专业实景影棚
1000平方米实景影棚
超2000平方米外拍基地
一流的影视设备
电影级摄像机、灯光设备、
专业航拍机等
资深制作团队
资深编导、策划、拍摄、
后期制作专业操刀
专业配音
80多位资深配音,支持
普通话、英文、方言等
免费创意提案
免费策划创意,创作文案及
分镜头脚本
项目修改满意为止
影片无理由、无限制修改,
直至满意
 

8月优惠超给力,一降到底,品质不打折,匠心制作!

企业宣传片

片长:60秒

 
专业配音|文案修饰|片头LOGO设计|画面制作|精修剪辑、配乐、调色、特效,后期制作
原价4600元

特惠:2300

企业宣传片(尊享版)

片长:60秒

 
专业配音|文案修饰|片头LOGO设计|视频与画面混编制作|精修剪辑、配乐、调色,特效,后期制作
原价5600元

特惠:2800

产品形象宣传片

片长:60秒-90秒

 
产品360度外观,真实专业拍摄|创意策划、音乐、特效、调色、后期制作
原价6400元

特惠:3200

产品介绍宣传片

片长:60秒-90秒

 
产品360度外观,真实专业拍摄|产品操作演示场景(含模特或主持人)画面拍摄|创意策划、音乐、特效、调色、后期制作
原价8600元

特惠:4800

成都高新区府城大道399号7栋2单元14层1404号

Chengdu Shilong  Pearson  Eucation  Science  and  technology  limited liability company

Chengdu high tech Zone Fucheng  Road  No.399 

Building  7  2  unit  14 floor  No.1404

    邮编(Zip Code):610000   

总机(搜狗认证电话): 028-67876373   

服务器虚拟备案空间服务商 北京息壤科技信息   

机房电话(TEL):0431-85769416

网址(Website)://www.maolg.net   

企业邮箱传真:4008266163-81212

电子邮箱(Email): public@maolg.com 推广链接

网络管理员(administrator): admin@maolg.com      

  ICP备案/许可证编号:蜀 ICP备17015012号-1

工商注册号:510109000979446


Copyright © 2016-2017 All Rights Reserved  

Chengdu  Shilong  Pearson  Education  Science  and technology  limited liability  company   

狮龙画廊

百度统计 


国际证书职业认证网址 http://www.icad.org.cn/

技术支持: 国际商业美术设计师协会高级美术设计师毛凌国.中国微软开发者网路平台

                 商务中国微信微舟央企贝力  PHP_WEB系统提供商